Vollversion 1.0.12 installieren über ECB 1.07

für Ankündigungen und Probleme beim Shop-Update

Vollversion 1.0.12 installieren über ECB 1.07

Beitragvon SvenB » Mi 21. Dez 2011, 15:32

Hallo zusammen,

fange gerade an mich mit dem Shop zu beschäftigen, da ich eine alte ECB 1.07 vorgesetzt bekommen habe, die nach Warenkorb->ZurKasse->Versandoptionen nicht mehr weiterspringt... :?
(Es sollte wohl irgendwas verändert werden in der Rechnungsansicht, was dies verursacht hat... Verursacher ist nicht mehr greifbar :roll: )
Als templates gibt es das gunnart_v1, yaml und ein angepasstes und umbenanntes gunnart_v1.

Ich dachte ich heb das gleich mal auf die webs 1.0.12 - mir wurde gesagt die kann das über den shop_installer updaten.
Also hab ich 1.0.12 über die 1.07. kopiert, das ganze hochgeladen und den shop_installer aufgerufen.
Nach der Meldung "Ihre DB muß aktualisiert werden von V1.0.10 auf V1.0.14" und klick auf Weiter hat das ganze dann gestoppt mit der Ausgabe einer langen Liste wie unten.

Bevor ich jetzt wild herumexperimentiere, dachte ich, ich frage hier erstmal genau nach, was ich tun muss, um das zum Laufen zu bringen.
Also kann mir jemand weiterhelfen? Wäre sehr dankbar...
Falls es dazu schon irgendwo was hilfreiches gibt, das ich nicht gefunden habe, würde mir auch der Link dazu willkommen sein ;-)

Gruß,
SvenB

-----
Datenbank Aktualisierung

Mailvorlage: templates/gunnart_v1/admin/mail/german/change_order_mail

veraltete Dateinamen
templates/gunnart_v1/admin/mail/german/change_order_mail.txt => templates/gunnart_v1/mail/german/admin_change_order.txt
templates/gunnart_v1/admin/mail/german/change_order_mail.html => templates/gunnart_v1/mail/german/admin_change_order.tpl
fehlerhafte Kopfzeilen
Bitte die Mailvorlage löschen oder die Kopfzeile aus templates/_core/mail/german/admin_change_order.txt übernehmen.

Mailvorlage: templates/gunnart_v1/admin/mail/german/create_account_mail

veraltete Dateinamen
templates/gunnart_v1/admin/mail/german/create_account_mail.txt => templates/gunnart_v1/mail/german/admin_create_account.txt
templates/gunnart_v1/admin/mail/german/create_account_mail.html => templates/gunnart_v1/mail/german/admin_create_account.tpl
fehlerhafte Kopfzeilen
Bitte die Mailvorlage löschen oder die Kopfzeile aus templates/_core/mail/german/admin_create_account.txt übernehmen.

[...]
SvenB
 
Beiträge: 2
Registriert: Mo 19. Dez 2011, 13:54

Re: Vollversion 1.0.12 installieren über ECB 1.07

Beitragvon Xantiva » Mi 21. Dez 2011, 17:51

Wenn Du auf die 1.0.12 aktualisierst, wirst Du um diverse Änderungen am Template nicht vorbei kommen. Wenn das nicht gewollt ist, bleibt die 1.0.9a. Danach hat es viele Änderungen gegeben.
Und ...
die nach Warenkorb->ZurKasse->Versandoptionen nicht mehr weiterspringt

... da wären mehr Informationen hilfreich! Ich vermute mal, das war nicht immer so? Was ist geändert worden? Gibt es eine Fehlermeldung? URL? Meine Glaskugel ist im Weihnachtsstress ;)

Ciao,
Mike
Mein Shop: http://www.basteln-selbermachen.de
Xantiva
 
Beiträge: 948
Registriert: Mo 10. Mai 2010, 18:26

Re: Vollversion 1.0.12 installieren über ECB 1.07

Beitragvon SvenB » Mi 21. Dez 2011, 19:17

Danke für deine Antwort, Mike!
...wirst Du um diverse Änderungen am Template nicht vorbei kommen.
Habs mir schon gedacht... und ich bereite mich schon darauf vor, die template-Dateien 1zu1 zu vergleichen, um die Änderungen festzustellen (vielleicht hilft da ja auch das DIFF-Skript aus dem Update-Bereich), damit ich dann die alten templates endsorgen und das webs-template anpassen kann.
mir ist bloß nicht ganz klar was gemeint ist:
veraltete Dateinamen
templates/gunnart_v1/admin/mail/german/change_order_mail.txt => templates/gunnart_v1/mail/german/admin_change_order.txt
"gefunden" => "musst das daraus machen" ? Reicht dann Verschieben und Umbenennen?
fehlerhafte Kopfzeilen
Bitte die Mailvorlage löschen oder die Kopfzeile aus templates/_core/mail/german/admin_change_order.txt übernehmen.
Sorry? Welche Mailvorlage? mail-Ordner im template? Löschen? (Hab etwas Nachsicht mit diesem Shop-Anfänger :oops: )

Was gewollt ist, ist, das der Shop wieder läuft, Version 1.0.12 wäre aber auch gut... ;-) Wenn ich aber Pech habe, tritt das Problem dann auch noch in 1.0.12 auf...

... die nach Warenkorb->ZurKasse->Versandoptionen nicht mehr weiterspringt

... da wären mehr Informationen hilfreich! Ich vermute mal, das war nicht immer so? Was ist geändert worden? Gibt es eine Fehlermeldung? URL? Meine Glaskugel ist im Weihnachtsstress ;)
Ne, das war nicht immer so, es soll mal funktioniert haben... wie gesagt, ich weiss nicht genau, was geändert wurde, da der Verursacher nicht mehr greif bar ist.
Einzige Info die ich bekommen konnte war: Rechnungslayout sollte angepasst werden mit Anzeige der 19%Mwst, Änderungen wurden über die DB versucht umzusetzen... Tja... Sorry...

Im Ablauf noch mal etwas genauer:
Bin im Warenkorb und will zur Kasse, "Zur Kasse"-Button bringt mich zu den Versandoptionen, Adresse wird angezeigt, die kann ich noch ändern, mach ich aber nicht, sondern will gleich auf "Weiter"... und dann passiert nichts mehr. Der Button "Weiter" bringt mich nur wieder in die Versandoptionen... ohne irgendeine Fehlermeldung.

Ist NICHT das Mindest-/Höchstbestellwert-Problem, bei dem man nicht zur Kasse gehen konnte, das sollte mit dem nötigen PHP-Code in der customers_status.php (ca. Zeile 79) gefixt sein:
Code: Alles auswählen
                // check for NULL values:
                foreach(array('customers_status_min_order', 'customers_status_max_order') as $name) {
                     if ($sql_data_array[$name] == '') {
                         $sql_data_array[$name] = 'null';
                     }
                }

Ich komme aber anscheinend nur einen Schritt weiter :(

Tipp zu deiner Glaskugel: nicht mehr schütteln, dann beruhigt sich auch das Schneegestöber wieder :mrgreen:

Gruß,
SvenB
SvenB
 
Beiträge: 2
Registriert: Mo 19. Dez 2011, 13:54

Re: Vollversion 1.0.12 installieren über ECB 1.07

Beitragvon Xantiva » Mi 21. Dez 2011, 21:00

SvenB hat geschrieben:Was gewollt ist, ist, das der Shop wieder läuft, Version 1.0.12 wäre aber auch gut... ;-) Wenn ich aber Pech habe, tritt das Problem dann auch noch in 1.0.12 auf...

Dann würde ich vorschlagen: Vergiss erst mal das Update und die ganzen Template Fragen. Das dauert u. U. länger. Zuerst sollte der Shop wieder laufen. Sonst hast Du wirklich alles geändert und es geht tatsächlich immer noch nicht.

SvenB hat geschrieben:Ne, das war nicht immer so, es soll mal funktioniert haben... wie gesagt, ich weiss nicht genau, was geändert wurde, da der Verursacher nicht mehr greif bar ist.
Einzige Info die ich bekommen konnte war: Rechnungslayout sollte angepasst werden mit Anzeige der 19%Mwst, Änderungen wurden über die DB versucht umzusetzen... Tja... Sorry...

Entweder debuggen oder zum Vergleich den originalen 1.0.7 herunterladen und die Dateien vergleichen, was verändert wurde ...

Ciao,
Mike
Mein Shop: http://www.basteln-selbermachen.de
Xantiva
 
Beiträge: 948
Registriert: Mo 10. Mai 2010, 18:26



Ähnliche Beiträge


Zurück zu Shop Updates

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast

cron