Keine Anhänge im Thunderbird, Update class.phpmailer.php

Du hast ein Problem gefunden und weißt nicht genau wo es hinpasst...
Antworten
Xantiva
Beiträge: 948
Registriert: Mo 10. Mai 2010, 16:26
Shop Version: 1.0.10 [dev]
Kontaktdaten:

Keine Anhänge im Thunderbird, Update class.phpmailer.php

Beitrag von Xantiva »

Hallo zusammen,

es gibt im Moment ein Problem mit den letzten Thunderbird - Versionen (> 3.x) und der aktuell verwendeten Version 5.1 von phpMailer. Betroffen sind in erster Linie alle, die Inline-Grafiken (Logo) und Datei - Anhänge mit den Emails versenden (z. B. AGB in der Bestellbestätigung!).

Mit den aktuellen Versionen zeigt der Thunderbird Anhänge in so einer E-Mail nicht mehr an! Sobald kleine Fehler in der Mailformatierung vorhanden sind, werden diese Anhänge im Moment einfach ignoriert. Sie sind im Nachrichtenquelltext vorhanden, werden aber einfach nicht angezeigt. Siehe auch "Angehängtes PDF nicht sichtbar" im Thunderbird - Forum, bzw. den Eintrag im Mozilla BugTracker.

phpMailer hat inzwischen reagiert und die Version 5.2 hat den Fehler nicht mehr. Die Anhänge werden damit im aktuellen Thunderbird auch wieder angezeigt.

ABER: Auf meinem Live - System hat es mit phpMailer v5.2 und dem Mailer qmail gleich eine Unverträglichkeit gegeben, daher gibt es leider noch keine endgültige Lösung für das Problem.
Hier ist die originale phpMailer v5.2. Ihr könnt (NACH BACKUP und am besten in einem Testsystem) diese im /includes/classes/ austauschen und testen, ob der Shop noch korrekt E-Mail versendet:
class.phpmailer.php.v5.2.zip
(17.83 KiB) 420-mal heruntergeladen
pop_und_smtp_5.2.0.zip
noch die class.pop.php und class.smtp.php
(8.64 KiB) 434-mal heruntergeladen
Wenn das Testsystem aber nicht 100% kompatibel ist, solltet Ihr auch im Live-System die Funktionalität auf jeden Fall noch einmal testen. Bei mir gibt es eine Unverträglichkeit mit qmail. Ab Zeile 705 musste ich erstmal folgende Änderung vornehmen (den Parameter "-oi" entfernen):

Code: Alles auswählen

    if (empty($this->Sender)) {
      // $params = "-oi -f %s";
      $params = "-f %s";
    } else {
      // $params = sprintf("-oi -f %s", $this->Sender);
      $params = sprintf("-f %s", $this->Sender);
    }
Beste Grüße,
Mike
Mein Shop: http://www.basteln-selbermachen.de

Doc Olson
Beiträge: 536
Registriert: Mo 10. Mai 2010, 08:54

Re: Keine Anhänge im Thunderbird, Update class.phpmailer.php

Beitrag von Doc Olson »

Wer vor allem rechtlich auf Nummer sicher gehen möchte, sollte die Widerufsbelehrung in TEXTFORM im Mail-Body mit unterbringen. Nur für den Fall, dass jemand eine angehängte PDF nicht sehen kann.

Frantek EL
Beiträge: 10
Registriert: So 1. Aug 2010, 16:54
Shop Version: ECB 1.02
Wohnort: Emsland
Kontaktdaten:

Re: Keine Anhänge im Thunderbird, Update class.phpmailer.php

Beitrag von Frantek EL »

Hallo,
habe die class.phpmailer.php.v5.2 von Mike eingebaut. E-Mail wird korrekt versendet aber nur 1 Anhang: logo.png, AGB.pdf ist nicht dabei. Hoffe das es so richtig eingebunden ist?

Code: Alles auswählen

 ** @Author: Jörg Wedekind <yogi@webs.de>
 ** @version $Id: order_mail.txt 2057 2011-03-29 08:11:17Z joerg $
 ** @copyright 2011 WEB-Shop Software http://www.webs.de/
 ** ------------------------------------------------------------------------- *}
ATTACHMENT: media/attachments/AGB.pdf
{if $toAdmin}
SUBJECT: [{$smarty.const.STORE_NAME}] Neue Bestellung: {$oID}
REPLY: "{$NAME}" <{$EMAIL}>
{else}
SUBJECT: [{$smarty.const.STORE_NAME}] Ihre Bestellung Nr. {$oID} / {$DATE}
{/if}

Hallo {$NAME},

herzlichen Dank für Ihre Bestellung.
Ein kleiner Tip der Hilft wäre Super - Danke
Gruß aus dem Emsland

F-J Surmann

Mein Shop: ebook1a.de

Xantiva
Beiträge: 948
Registriert: Mo 10. Mai 2010, 16:26
Shop Version: 1.0.10 [dev]
Kontaktdaten:

Re: Keine Anhänge im Thunderbird, Update class.phpmailer.php

Beitrag von Xantiva »

ATTACHMENT: media/attachments/AGB.pdf
Ist das s dahinten richtig?
Mein Shop: http://www.basteln-selbermachen.de

Frantek EL
Beiträge: 10
Registriert: So 1. Aug 2010, 16:54
Shop Version: ECB 1.02
Wohnort: Emsland
Kontaktdaten:

Re: Keine Anhänge im Thunderbird, Update class.phpmailer.php

Beitrag von Frantek EL »

Xantiva hat geschrieben:
ATTACHMENT: media/attachments/AGB.pdf
Ist das s dahinten richtig?
Nein! - das war es

PS:
Mit den Leuten Hier, macht es auch wieder Spass am Shop zu Arbeiten.

nochmals Danke
Gruß aus dem Emsland

F-J Surmann

Mein Shop: ebook1a.de

Antworten